Previous Message
Next Message

Menu working as expected in Firefox but not IE

Sent by francky on 30 March 2006 04:04


Veign wrote:

>Big surprise to the group I'm sure <g>
>
>I have a menu that works as expected in Firefox but I can't get it to work
>in IE.  I have tried everything and searched high and low but nothing. I
>stripped out everything except what the problem is.
>
>Test Page:
>http://veign.com/preview/menu/menu.html
>
>CSS:
>http://veign.com/preview/menu/style.css
>
>Problem:
>Hover effect doesn't show properly in IE.  Also, page needs to stay in a
>table cell (hands are tied on this one).
>
>Chris
>  
>
Hi Chris,
1.
Before I try everything and search high and low, sometimes I don't 
forget to validate.
The html-validator 
<http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fveign.com%2Fpreview%2Fmenu%2Fmenu.html> 

reports there is no charset, and the <div> is missing the </div> end 
tag; probably get lost in one of your versions. Surprise! ;-)
What happens after repairing this?

2.
It seems the #mainmenu {height: 30px} is prohibiting the cell/table to 
expand > giving also troubles in FF when then visitor has scaled up the 
fontsize. The fixed height causes the menu-items are coming out of the box.

3.
If you don't have planned dropdown submenu's, the sfHover-script is not 
needed, I think: a css-hover is enough. - If you want to make submenus, 
then the class ".sfhover" has to be added in the li-style. See 
Suckerfish-article <http://www.htmldog.com/articles/suckerfish/dropdowns/>.

Greetings,
francky



______________________________________________________________________
css-discuss [EMAIL-REMOVED]]
http://www.css-discuss.org/mailman/listinfo/css-d
IE7b2 testing hub -- http://css-discuss.incutio.com/?page=IE7
List wiki/FAQ -- http://css-discuss.incutio.com/
Supported by evolt.org -- http://www.evolt.org/help_support_evolt/
Previous Message
Next Message

Message thread: