Previous Message
Next Message

Applying A Border To <tr>

Sent by Michael Warkentin on 22 March 2006 16:04


I'm having an issue with styling a table.  Everything is working great, but
when I try to apply a border to the <tr> elements, nothing shows up.  If I
view the element in the IE DOM inspector, it shows that there should be a
border.  I don't have access to an outside server to put up my example, but
the relevent code is below.  If you need anything else, let me know..

Cheers,
Mike

Here is my HTML:

<table class="table1">
                        <thead>
                            <tr>
                            <th colspan="2">NEWS</th>
                            </tr>
                        </thead>
                        <tbody>
                            <tr>
                            <td><img src="images/thumb_50wide.png" alt="news
thumbnail" /></td>
                            <td>Lorem ipsum dolor sit amet, consectetuer
adipiscing elit. Nunc suscipit orci ut magna.</td>
                            </tr>
                            <tr>
                            <td><img src="images/thumb_50wide.png" alt="news
thumbnail" /></td>
                            <td>Lorem ipsum dolor sit amet, consectetuer
adipiscing elit. Nunc suscipit orci ut magna.</td>
                            </tr>
                            <tr>
                            <td><img src="images/thumb_50wide.png" alt="news
thumbnail" /></td>
                            <td>Lorem ipsum dolor sit amet, consectetuer
adipiscing elit. Nunc suscipit orci ut magna.</td>
                            </tr>
                        </tbody>
</table>

And my CSS:

/* TABLES */
    .table1 {width:281px;margin:0px 10px 10px 0px;float:left}
        .table1 td {background: #fff;padding:3px;}
        .table1 th {text-align:left;border: 1px solid #fff}
        .table1 thead th {color:#3C4C65;font-size:110%;background:
#B0F1F7;padding: 6px}
        .table1 tbody th {color:#fff;font-size:115%;background: #88b8db
url("images/sprites.gif") repeat-x 0 -1400px;padding: 6px;}
        .table1 tbody tr {border: 1px solid #000;}   /* Border which isn't
displaying */
        .table1 tbody th.sub {font-size:100%;color:#000;background: #efefef
url("images/sprites.gif") repeat-x 0 -1500px;padding: 6px}
______________________________________________________________________
css-discuss [EMAIL-REMOVED]]
http://www.css-discuss.org/mailman/listinfo/css-d
IE7b2 testing hub -- http://css-discuss.incutio.com/?page=IE7
List wiki/FAQ -- http://css-discuss.incutio.com/
Supported by evolt.org -- http://www.evolt.org/help_support_evolt/
Previous Message
Next Message

Message thread: